MikroTik RouterOS 6.45.9 for KVM

 

مدتی بود که میخوام سیستم عامل MikroTik RouterOS رو برای مجازی ساز KVM باهاتون به اشتراک بذارم اما به دلیل ذیق وقت موفق نمیشدم. امروز دیگه فرصت پیدا کردم و این راوتر فوق العاده کاربردی و کاربرد پسند رو باهاتون به اشتراک میذارم.

منم مثل مدیران شبکه ای که سرشون خیلی شلوغه (!) و فرصت ندارن که ROS رو آپدیت کنن و بعد بخاطر وجود یه bug توش برگردن به نسخه قبل، چون معمولاً نیازی به آخرین تغییرات کانال Stable ندارم و صرفاً تغییرات امنیتی رو نیاز دارم، از کانال Long-term این محصول استفاده میکنم. بنابراین نسخه ای که باهاتون به اشتراک گذاشتم آخرین نسخه از کانال Long-term یعنی 6.45.9 هست. اگه شما مایل هستید که از کانال Stable استفاده کنید خودتون به راحتی می تونید این کار رو با آپدیت کردن انجام بدید.

مثل همیشه لایسنس سطح 6 هست که بیشترین قابلیت ها رو در اختیارتون قرار میده.

ماشین به صورت یه هارد دیسک با فرمت qcow2 در اختیارتون قرار گرفته که کسانی که توی مجازی سازی روی لینوکس و KVM تجربه دارن میدونن که فرمت مرسوم ارائه ماشین مجازی روی این پلت فرم هست. در واقع این فایل یه هارد دیسک هست که شما یه ماشین مجازی رو تحت مجازی ساز خودتون میسازید و این فایل رو به عنوان هارد دیسک به ماشین مجازی تون میدید. فقط دقت کنید که باید Bus type مربوط به هارد دیسک رو روی IDE بذارید.

سایز هارد دیسک هم 1 گیگابایت هست بنابراین دوستان و همکاران عزیز برای اضافه کردن package و آپدیت آنلاین مشکلی نخواهند داشت.

یه نکته دیگه که توجه بهش مهم هست اینه که MikroTik RouterOS اگه MAC Address کارت شبکه شما تغییر کنه، همچنان از MAC Address قبلی استفاده میکنه تا زمانی که بهش بگید که اونو Reset کنه و از کارت شبکه مجدداً بخونه. من خیلی وقت پیش یه پست در این مورد نوشتم، اما دیگه شما رو به اون پست ارجاع نمیدم و همین جا دستور مورد نیاز برای این کار رو میگم. فرض کنید که میخوام این کارو برای اولین کارت شبکه انجام بدم:

/interface ethernet reset-mac-address numbers=0

که اون عدد 0 (صفر) نشون دهنده کارت شبکه اول هست. چون شمارش از 0 شروع میشه.

چون این سؤال به کرات پرسیده میشه، اشاره میکنم که در RouterOS شرکت MikroTik در حالت پیش فرض نام کاربری admin هست و برای این نام کاربری رمزی قرار داده نشده.

امیدوارم برای دوستان مفید واقع بشه.

اینم اسکرین شات من که دارم این ماشین مجازی رو روی سیستم عامل CentOS 7 و با استفاده از virt-manager شرکت Red Hat اجرا میکنم.

قبل از اینکه پست رو تموم بکنم یه پاراگراف رو برای اونایی که یه مقدار ریزبین تر هستن یا اینکه متخصص مجازی سازی هستن، اضافه میکنم. علی رغم اینکه من توی متن و عنوان پست اشاره کردم که این ماشین برای مجازی ساز KVM هست اما در حقیقت یه سیستم مجازی سازی از اجزایی تشکیل شده که یه قسمت اون، Emulation مربوط به CPU هست. در حقیقت معروفترین مجازی ساز در پلت فرم لینوکس QEMU هست که کار مجازی سازی یه سیستم کامل رو انجام میده و خودش هم توی خودش امولاتور CPU داره اما روی پلت فرم x86 برای اینکه بتونه Instruction Set Emulation رو با سرعت بیشتر انجام بده و کاربر احساس کنه که ماشین مجازی سریع داره اجرا میشه عمدتاً از Hardware Acceleration ارائه شده توسط KVM استفاده میکنه. بین مدیران شبکه (مثل خود من) این جزئیات و بحث های فنی اهمیت کمتری داره و ما به کل این سیستم با اغماض KVM میگیم که صحیح ترش QEMU/KVM هست. مثل وقتی که با اغماض به GNU/Linux میگیم لینوکس. پس خواهش میکنم که بر ما مدیران شبکه ببخشید. اون چیزی که برای ما مهمه اینه که بتونیم یه ماشین مجازی رو روشن کنیم و باهاش تو شبکه سرویس بدیم!

با مقدمه ای که بالا گفته شد و با توجه به اینکه QEMU روی سیستم عامل ویندوز هم اجرا میشه، شما می تونید روی ویندوز هم از این ماشین مجازی استفاده کنید. البته روی ویندوز یا باید از امولاتور CPU خود QEMU استفاده کنید یا اینکه می تونید از HAXM به جای KVM استفاده کنید که سرعت اجرا رو بهبود میده اما من شخصاً روی لینوکس با KVM خیلی راضی تر از روی ویندوز با HAXM بودم.

Link: mikrotik-routeros-6.45.9-kvm.rar

Size: 60 MB

SHA1: 6d2d9fa242e57b40bd938af344a808d7f386ad7e

Password: www.digiboy.ir

۱۸ دیدگاه نوشته شده است! می توانید دیدگاه خود را بنویسید

  1. reza گفت:

    سلام
    خیلی ممنون از شما
    لطفا نسخه vmware رو هم به اشتراک بذارید.

    • یوسف گفت:

      دوست عزیز سلام
      شما بسادگی میتونید آخرین نسخه سایت ما رو بصورت آنلاین بروز کنید.
      لایسنس معتبر و قابلیت بروز رسانی خواهد داشت.
      تمامی نگارش های این نرم افزار از سایت ما گرفته شده و فقط بروز رسانی کردند.

  2. یوسف گفت:

    محمد عزیز کارت حرف نداشت
    ممنون

  3. امیر گفت:

    سلام

    خیلی خیلی ممنون

    فقط اگر لطف کنید و نسخه vmware با هارد 1 گیگ رو هم بگذارید خیلی خوب میشه

  4. محمد گفت:

    سلام امکانش هست این ماشین رو با 5 گیگ هارد دیسک کرک کنید ممنون

  5. محمدیوسف گفت:

    سلام و عرض ادب.
    اول تشکر می‌کنم و خسته نباشید می‌گم بخاطر اشتراک و توضیحات کامل.
    دوم راهنمایی میخوام برای اینکه بتونم این میکروتیک را روی هایپروی اجرا کنم. اگر هاردش را کانورت کنم لایسنس می‌پره. هیچ راهی وجود نداره؟

    ممنون از توجهتون

  6. mehdi گفت:

    ممنونم و متشکر از ارائه بروز این نسخه از میکروتیک.

  7. رضا گفت:

    با سلام و تشکر
    آیا امکانش هست نسخه تحت Hyper-V رو هم بگذارید؟ ممنون میشم

  8. احمد گفت:

    سلام
    من روی virtualizor نصب کردم روشن کردم این تمپلیت
    اما متاسفانه کارت شبکه نمیشناسه
    مجازی ساز سرور هم kvm هست .
    دستور ip address print میزنم هیچ نتورکی نمیبینم

    • محمد گفت:

      نوع کارت شبکه رو روی یکی از انواعی بذارید که MikroTik درایورش رو داشته باشه. در حال حاضر RouterOS درایورهای Paravirtualized رو نداره.

      • احمد گفت:

        میکروتیک chr کارت شبکه این مجازی ساز میشناسه
        اما این نسخه نمیشناسه
        کارت شبکه Intel E1000،virtio،Realtek 8139 داره که هر سه نمیخونه
        امکان بررسی این مورد هست ؟

    • محمد گفت:

      خب برای دیدن کارت شبکه که نباید اون دستور رو بزنید!
      می تونید از این دستور استفاده کنید:
      /interface ethernet print
      اگه می خواید به یه interface آی پی استاتیک بدید، باید این دستور رو بزنید:
      /ip address add interface=ether1 address=192.168.200.1/24
      اگه می خواید به یه interface آی پی دینامیک بدید، باید این دستور رو بزنید:
      /ip dhcp-client add interface=ether1 disabled=no
      برای مطالب بیشتر به مستندات شرکت میکروتیک مراجعه کنید.
      *در مثال های بالا من فرض رو بر این گذاشتم که اسم اینترفیس شما ether1 باشه.*

      • احمد گفت:

        سلام
        با تشکر از شما
        حق با شما بود مشکل حل شد و آی پی گرفت سرور

        فقط یک سوال نسخه کرک شده نیست !
        لایسنس میخواد میکروتیک

        آیا راه حلی برای این موضوع هست ؟

  9. heidari گفت:

    سلام
    چطور میتونم روی esxi 6 نصب کنم؟

  10. جواد گفت:

    با سلام و تشکر فراوان از سایت خوبتون
    ببخشید می خواستم بپرسم چقدر این نسخه قابل اطمینانه؟
    منظورم اینه که (با وجود اینکه تعداد خیلی زیادی از این نسخه استفاده می کنن) اگر مثل اصلی با لایسنس پولی کار می کنه که دنبال لایسنس پولی و اصلیش نرم
    اگرم نه نسخه پولیش استیل تر و قابل اطمینان تره که سراغ این نسخه نیام
    چون یه ماشین مجازی میکروتیک لازم دارم گفتم بپرسم از خدمتتون شما تجربه تون خیلی بالاتره مسلما بهتر می تونید راهنماییم کنید

  11. عمرانی گفت:

    سلام و وقت بخیر

    لطفابرای hypr-v هم اگر امکانش هست بزارید.
    خیلی ممنون

  12. مهدی نجاریان گفت:

    سلام روز بخیر روی سولوس وی ام solusvm چطور باید این پکیج اضافه بشه
    باید پکیج بصورت خروجی برای سولوس باشه

دیدگاه خود را به ما بگویید.